14.3 C
Byron Shire
April 12, 2021

Latest News

Essential businesses recognised

A sticker initiative, to say ‘Thank you’ and support local retailers’ doing it tough is adorning Mullum shops, owing in part to efforts by resident Angela Bambach.

Other News

Armed robberies in Northern Rivers

Police have been investigating two armed robberies this week, one in Byron Bay and one in Lismore.

New film celebrates getting back outside

'Free From Lockdown: Back Out in Nature' is a new short film in which a group of disabled and non-disabled performers from the Northern Rivers celebrate being in nature after COVID lockdown.

ANZAC Day with a difference in Lismore

The Northern Rivers peace group ‘Remembering and Healing’ (RaH), now in its twelfth year, is organising two public events for ANZAC Day to remember the suffering war brings on all sides, and to make a strong commitment to peace and non-violence.

Hassle councillors, not Council staff

Duncan Dey, Byron Greens council candidate 2021 –Main Arm The Echo’s article of 10 March implied that it was Council...

Mullum farmer’s market closed this Friday

This Friday's Mullum Farmer's Market has been cancelled due to the decimation of the site by rain.

Council crews working hard to repair potholes

Tweed Shire Council road maintenance crews are out across the Tweed's road network repairing potholes and other damage caused by the recent prolonged rainfall and previous flood events.

March 17, 2021

Issue 35.40

Download PDF (18MB)

Jump to:

Local News | Comment | Letters | Articles | Health & Healing | The Good Life | Good Taste | Seven Entertainment | Gig Guide | Stars | Cinema | Echo Property | Service Directory | Classifieds | Community at Work | Backlash

In this Issue:

Think globally act locally – make a difference

In late 2020 the Narendra Modi government in India hastily passed three laws pertaining to Indian agriculture, claiming that they would improve farmers’ lives.

0

Dear Penny Wong

Gareth W R Smith, Palestine Liberation Centre How can you, in all conscience, assert the ALP’s undying support for the apartheid state of Israel whose litany of egregious crimes against humanity (see B’Tselem and Breaking the Silence, for example) are so...

3

Trains and bikes

Jan Mangleson, Northern Rivers Rail Ltd I believe the Northern Rivers community is about to lose one of its most important assets, taken away by our own NSW state parliament. Federal and State money has been given to a small lobby...

7

Look within

Robert Podhajsky, Ocean Shores It is any wonder that there are all these troubles present in our society – when our internal nature is not regarded as a necessary function, and is constantly disregarded in the structures we live with. How...

0

China bashing

Christine Olsen, Brunswick Heads I was surprised to see The Echo joining in on the current media bout of China bashing (Backlash 10 March ‘Tik Tok is Chinese-owned psyops’). I thought you were above that. It is in fact the US who...

5

Taking on the leadership challenge

How do you create a leader? Leaders are everywhere; from your favourite footy captain to the prime minister. But how do these types of people arise, and how do we raise people in the hope of inspiring them to leadership?

2

A royal culture

Bronwyn Sindel, Mullumbimby I can’t help but comment on last week’s Backlash regarding the nationality of the Royal Family of Great Britain. Using the same concept one would have to say that all non-Aboriginal people are not Australian; they are English,...

0

The ‘L’ word

Deborah Lilly, Mullumbimby ‘International Ladies Day’? No way! That’s pathetic. It’s time we stood up as women and put an end to being defined by an outdated patriarchal moniker. To call a woman a lady is a social construct that flatters, cajoles,...

1

Bygones be bygones

Matthew O’Reilly, Greens candidate 2021 Both Basil Cameron and Cate Coorey have done a terrific job on Byron Council as progressive councillors unaligned with any political party. I was really pleased to see in Basil’s letter (10 March) that he has not...

2

Byron bus interchange

Donald Maughan, President BBHS Like most, I’ve been watching the development of the new bus interchange on Butler Street, Byron Bay with a mixture of interest and concern. As a representative of the Byron Bay Historical Society (BBHS), I recently had the...

0

Permaculture legend Holmgren to appear at Renew Fest

Legendary co-founder of permaculture practice, David Holmgren, is coming to the Northern Rivers in May, appearing as a headliner guest at Renew Fest in Mullumbimby.

0

Byron Council in court with Reflections Holiday Parks

NSW run corporation Reflections Holiday Parks has taken Byron Shire Council to court over a deemed refusal of activity approval for the southern section of Terrace Reserve in Brunswick Heads.

1

All Girls Surfriders back in the water for 30th anniversary year

The All Girls Surfriders club based in Lennox Head is up and running for the season and looking forward to celebrating its 30th birthday later in the year.

0

Surfing To Survive

Surfing To Survive is a film about local surfer and surf coach Karin, with an invisible illness leading to disability, and will show at the Palace Cinema Byron on 19 March at 6.45pm.

0

Wedging residents against developers

Are you aware that Byrons ‘Greens’ mayor Simon Richardson is actively wedging residents, who face large inappropriate DAs in their neighbourhood, against developers?

2

Senior cricket premierships on the line this weekend

Cudgen will feature in the top two grades of cricket finals this weekend as they take on Marist Brothers Lismore in the LJ Hooker one-day league and Bangalow in the Coastal League.

2

Law change needed to protect domestic violence victims

Getting affordable accommodation is hard enough, but for a single mother with a child it can be harder and riskier than for your average single person.

3

Surveillance law could target and fine protesters

Proposed federal cyber laws, if passed, would pose ‘significant risks’ around the rule of law doctrine and the separation of powers, says Law Council president, Dr Jacoba Brasch QC.

3

Saddle Road DA aims to pioneer a ‘new definition of affordable...

A Development Application (DA) for six farm stay accommodation units and a central facility on the southern end of Saddle Road is up for public comment.

5

Football looking forward to another big year

Local teams are encouraging more female players to join the game as Northern NSW Football pushes to make the 2021 season the biggest yet for women’s football across its seven member zones.

1

Byron Council staff to pursue solutions to assist ‘key workers’ 

Are all private housing developments greed-driven enterprises that should be stopped from destroying our peaceful towns and villages?

2

Coat of tarnish

Tom Tabart, Former Greens councillor I can understand Cr Cameron wishing to tarnish The Greens as a prop for his long-standing desire to be mayor. But surely the current ‘Richardson’ Greens have done enough to damage the brand themselves? As someone who...

0

Affordable housing?

Annie Radermacher, Brunswick Heads The affordable-housing boarding house SEPP fails to provide any affordability. State government has to revisit the affordability of the existing boarding house SEPP because not one room could be deemed as affordable. This is because there is...

0

Greatest of thanks

Cherie & Derek Holden, Newport My husband and I are having a couple of days’ break in Brunswick Heads on our drive home from Noosa to Sydney. Yesterday while driving around Bangalow our car suddenly stopped, showing the red light for oil....

0

Encampments

Peter Olson, Goonengerry Logic suggests that there will be one or two orders of magnitude increase in homeless encampments or tent communities within the local parks of the north coast. Since they could not be stopped in other countries, it is...

1

Francis Cloake in running for National Portrait Prize

Byron Bay's Francis Cloake is one of two Northern Rivers photographers named as a finalist in the prestigious Living Memory: National Photographic Portrait Prize.

Policy not ‘housekeeping’

Heather Martin, Mullumbimby According to a report in The Echo (24 March), the planning staff’s proposed amendments to LEP 2014 include a blanket prohibition on...

Exactly how was the ship stuck?

Peter Olson, Goonengerry It is well known that The Echo does not publish fake news, so since the Australian media has clearly stated that the...

A win for the roughy

The battle for the 'roughy had been a tough road for conservationists and hopefully this win will be the last fight.